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Subject: Computer

Duration (Periods): 2

Lesson Name: PowerPoint 2016: Advanced Features

Overview: A presentation can be enhanced by using various features of PowerPoint.

Prior Knowledge: The students have basic knowledge of creating presentations.

Learning Outcomes:
At the end of the lesson, the student will be able to: 

	• insert media to a presentation.
	• use Action Buttons.

	• print a presentation.

Teaching Aids: 
	• https://www.geeksforgeeks.org/how-to-insert-video-in-microsoft-powerpoint/

	• https://support.microsoft.com/en-us/office/add-commands-to-your-presentation-with-
action-buttons-7db2c0f8-5424-4780-93cb-8ac2b6b5f6ce

Learning Segments:

LESSON LINK
Time: 05 minutes

Purpose: Brief 
introduction/discussion to 
pique students’ interest.

Greet the class and introduce the topic:
	• PowerPoint 2016 enables us to insert media in the 

presentation. 
	• We can make the presentations more interesting using 

media.

LESSON EXECUTION
Time: 25 minutes

Purpose: Engagement of 
both teacher and students 
to achieve the learning 
outcomes.

Period 1
	• Elaborate upon the importance of media in a 

presentation.
	• Demonstrate the method to add audio and video to a 

presentation.
	• Explain the meaning of Action Buttons.
	• Demonstrate the steps to add Action Buttons.

Period 2
	• Read out the rubrics in the Skill Drill section and 

encourage the students to indulge in the task 
individually.

	• Ensure that each student has completed the task.

1.  PowerPoint 2016: Advanced Features

Galaxy_DigiVerse_Book-6_TRM.indd   3Galaxy_DigiVerse_Book-6_TRM.indd   3 05-03-2024   12:05:3705-03-2024   12:05:37



DigiVerse 64

LESSON CLOSURE
Time: 05 minutes

Purpose: Summarising the 
key points and reinforcing 
the learning outcomes of 
the lesson.

	• Discuss the answers to the questions.
	• Recapitulate the topics discussed in the lesson.

Answer Key [Chapter 1]

A.	 Tick () the correct option.
1.	 c. Action Settings 	 2.	 b. File	 3.	 a. Media
4.	 b. Print All Slides	 5.	 c. Record Audio

B.	 Fill in the blanks using the words in the box.
1.	 Insert	 2.	 Action	 3.	 Playback	 4.	 video
5.	 Online Videos

C.	 Write T for True and F for False statements.
1.	 F	 2.	 F	 3.	 F	 4.	 T
5.	 T

D.	 Answer the questions in a few words.
1.	 The Backstage View appears when we click on the File tab.
2.	 We find the Action Buttons category in the Shapes menu.
3.	 We add video files from the Insert tab.
4.	 The options available in the Video command drop-down menu are: Online Video 

and Video on My PC.
5.	 We select the ‘Audio on My PC’ option to add an audio saved on the computer.

E.	 Answer the following questions.
1.	 In a presentation, we can either add a video saved from the device or we can add 

a video from the Internet.
2.	 If we click on the ‘Mouse Click’ tab, then we will have to click on the added Action 

Button so that it can perform the action that has been assigned to it.
3.	 The steps to print a presentation are:

•	 Click on the File tab. The Backstage View will appear.
•	 Select the Print option from the left pane. The Print screen will appear.
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Subject: Computer

Duration (Periods): 2

Lesson Name: Excel 2016: Formatting

Overview: We can make changes in an Excel sheet to emphasise on important data.

Prior Knowledge: The students have basic knowledge of using Excel 2016.

Learning Outcomes:
At the end of the lesson, the student will be able to: 

	• format cells in a worksheet.

	• format a worksheet.
	• customise a worksheet.

	• use the AutoFill feature.

Teaching Aids: 
	• https://support.microsoft.com/en-us/office/apply-create-or-remove-a-cell-style-

472213bf-66bd-40c8-815c-594f0f90cd22

	• https://www.ablebits.com/office-addins-blog/autofill-excel/

2.  Excel 2016: Formatting

•	 The Print screen has different options for printing the slides. We can choose 
any option according to our preference:
o	 ‘Print All Slides’ option will print all the slides of the presentation.
o	 ‘Print Selection’ option will print only the selected slides of the presentation.
o	 ‘Print Current Slide’ option will only print the slide that was open when we 

selected the Print option.
o	 ‘Custom Range’ option will allow us to enter the number of specific slides 

that we want to print.
•	 Select a Print Layout for printing the slides. 
•	 Click on the Print button.

4.	 Action Buttons are built-in shapes that perform a specified action once we click 
or hover the mouse pointer over them. We can specify the action of each Action 
Button that we add to the slide.

5.	 The two options in the Audio command drop-down menu are:
•	 ‘Audio on My PC’ option is used to select a saved audio from the computer.
•	 ‘Record Audio’ option is used to record an audio for the presentation.
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Learning Segments:

LESSON LINK
Time: 05 minutes

Purpose: Brief 
introduction/discussion to 
pique students’ interest.

Greet the class and introduce the topic:
	• Excel provides various tools and features to format 

the cells.
	• We can use those features to enhance the look of a 

worksheet.

LESSON EXECUTION
Time: 25 minutes

Purpose: Engagement of 
both teacher and students 
to achieve the learning 
outcomes.

Period 1
	• Demonstrate the method to format cells in a 

worksheet, insert rows and columns, format a 
worksheet and customising the worksheet tab.

	• Explain the usage of the AutoFill feature.
	• Demonstrate the steps to use the AutoFill feature.

Period 2
	• Read out the rubrics in the Skill Drill section and 

encourage the students to indulge in the task 
individually.

	• Ensure that each student has completed the task.

LESSON CLOSURE
Time: 05 minutes

Purpose: Summarising the 
key points and reinforcing 
the learning outcomes of 
the lesson.

	• Discuss the answers to the questions.
	• Recapitulate the topics discussed in the lesson.

Answer Key [Chapter 2]

A.	 Tick () the correct option.
1.	 c. 15 	 2.	 b. Cell Styles	 3.	 a. Fill Handle	 4.	 b. Copy
5.	 c. Unmerge

B.	 Fill in the blanks using the words in the box.
1.	 double-click	 2.	 single cell	 3.	 AutoFill	 4.	 Number Format
5.	 Font

C.	 Write T for True and F for False statements.
1.	 F	 2.	 T	 3.	 F	 4.	 T
5.	 F
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D.	 Answer the questions in a few words.
1.	 We click on the Insert command from the Cells group on the Home tab to insert 

rows in a worksheet.
2.	 Splitting the cells is the opposite of merging the cells. We split the cells to divide 

a single cell back to the number of cells there were before merging.
3.	 The default column width is 8.43 characters.
4.	 The ‘Fill Color’ command is used for filling colour in a cell.
5.	 We select an entire worksheet by pressing the keys Ctrl + A.

E.	 Answer the following questions. 
1.	 The steps to remove cell borders are:

•	 Select the cell range for which you want to add a cell border.
•	 In the Home tab, click on the arrow next to the Border command in the Font 

group.
•	 Select the No Border option from the drop-down menu.

2.	 The steps to change the row height are:
•	 Select the row(s) to change its height.
•	 Click on the Home tab and select the Format command from the Cells group. 

A drop-down menu will appear.
•	 Select the Row Height option from the Cell Size heading. A Column Width or 

Row Height dialog box will appear on the screen.
•	 Type the value in the Row Height box to define the row height.
•	 Click on the OK button to see the changes.

3.	 Cell Styles can be used to bring focus to the important parts of the data or to 
enhance the appearance of data. We can choose different cell colours, borders, etc.

4.	 The steps to format numbers in a cell are:
•	 Select the cells for which you want to change the number format.
•	 On the Home tab, click on the arrow in the Number Format box from the 

Numbers group.
•	 Select any number format that you want to apply.

5.	 The ‘Copy’ command makes a copy of the data, without deleting it from its original 
place. The steps to copy/move the data are:
•	 Select the cells that you need to move or copy.
•	 Click on the Home tab and select the Cut/Copy command from the Clipboard 

group.
•	 Click on the cell where you want to paste the data.
•	 Click on the Home tab and select the Paste command from the Clipboard group.
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Subject: Computer

Duration (Periods): 2

Lesson Name: Excel 2016: Formulas and Functions

Overview: We can use various formulas and functions to manipulate the data in Excel.

Prior Knowledge: The students have basic knowledge of using Excel.

Learning Outcomes:
At the end of the lesson, the student will be able to: 

	• use formulas in a worksheet.

	• understand the concept of cell references.

	• name a cell range.

	• define and use a function.

Teaching Aids: 
	• https://i.pinimg.com/736x/51/9f/be/519fbe109664a58cefd7d3084041ad1d.jpg

	• https://support.microsoft.com/en-us/office/excel-functions-alphabetical-b3944572-
255d-4efb-bb96-c6d90033e188

Learning Segments:

LESSON LINK
Time: 05 minutes

Purpose: Brief 
introduction/discussion to 
pique students’ interest.

Greet the class and introduce the topic:
	• Excel formulas and functions stand out as its most 

useful features.
	• We use formulas and functions to generate or 

manipulate the data.

LESSON EXECUTION
Time: 25 minutes

Purpose: Engagement of 
both teacher and students 
to achieve the learning 
outcomes.

Period 1
	• Define the meaning and usage of formulas, functions 

and cell references.
	• Elaborate upon the types of cell references.
	• Demonstrate the steps to name a cell range.
	• Discuss the various types of functions.

Period 2
	• Read out the rubrics in the Skill Drill section and 

encourage the students to indulge in the task 
individually.

	• Ensure that each student has completed the task.

3.  Excel 2016: Formulas and Functions 
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LESSON CLOSURE
Time: 05 minutes

Purpose: Summarising the 
key points and reinforcing 
the learning outcomes of 
the lesson.

	• Discuss the answers to the questions.
	• Recapitulate the topics discussed in the lesson.

Answer Key [Chapter 3]

A.	 Tick () the correct option.
1.	 a. Arguments	 2.	 c. Enter	 3.	 c. Formulas	 4.	 b. Largest
5.	 b. (TODAY())

B.	 Fill in the blanks using the words in the box.
1.	 mixed	 2.	 CONCATENATE	 3.	 cell range	 4.	 parentheses
5.	 MOD

C.	 Write T for True and F for False statements.
1.	 T	 2.	 T	 3.	 T	 4.	 F
5.	 F

D.	 Answer the following questions.
1.	 We use formulas to perform various calculations automatically, from basic to 

complex. By using formulas, we can create new values from existing ones.
2.	 The two ways to enter a formula in a worksheet are:

•	 We can enter the formula directly in an active cell after typing equal (=) sign. 
After pressing the Enter key, the result will be displayed in the cell.

•	 We can also enter the formula in the Formula Bar after selecting a cell form the 
worksheet. The result will be displayed in the cell after pressing the Enter key.

3.	 The rules to follow while entering a function in Excel are:
•	 Every Excel function starts with an equal (=) sign.
•	 We need to use a valid Excel function name.
•	 Open and close parentheses are necessary after mentioning a function.
•	 For most functions, including an argument within the parentheses is required.

4.	 There are three types of cell references in Excel:
•	 Relative Reference: When creating a formula within a cell, we incorporate 

references to other cells or ranges to obtain an outcome in that particular cell.
•	 Absolute Reference: We use absolute references when we want to keep the 

same cell address in a formula while copying it to another cell. 
•	 Mixed Reference: Mixed reference is a combination of relative and absolute 

references. In this type of reference, either the column name or the row number 
stays fixed.
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5.	 The steps to use the COUNT (range) function are:
•	 Write the = YEAR (TODAY()) function in a cell.
•	 Press the Enter key from the keyboard. The current year will be displayed in  

the cell.
	 The steps to use the TODAY () function are:

•	 Type the =TODAY () in a cell.
•	 Press the Enter key. The current date will be displayed in the cell. 

4.  Using Adobe Animate 2020 

Subject: Computer

Duration (Periods): 2

Lesson Name: Using Adobe Animate 2020

Overview: Adobe Animate is a computer animation software created by Adobe Inc.

Prior Knowledge: The students are familiar with the concept of animations.

Learning Outcomes:
At the end of the lesson, the student will be able to: 

	• create a file in Adobe Animate CC.

	• identify the components of Animate CC window.
	• use various tools of Animate CC.

	• save a file.

Teaching Aids: 
	• https://helpx.adobe.com/in/animate/using/workflow-workspace.html

	• https://helpx.adobe.com/in/animate/using/using-stage-tools-panel.html

Learning Segments:

LESSON LINK
Time: 05 minutes

Purpose: Brief 
introduction/discussion to 
pique students’ interest.

Greet the class and introduce the topic:
	• Adobe Animate CC is a powerful tool used for 

creating interactive and animated content for 
various purposes, including web design, multimedia 
presentations, online advertising, games, etc.

	• It allows users to design and animate vector graphics, 
raster graphics and even multimedia elements.
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LESSON EXECUTION
Time: 25 minutes

Purpose: Engagement of 
both teacher and students 
to achieve the learning 
outcomes.

Period 1
	• Point out and explain the components of the Adobe 

Animate window.
	• Demonstrate the steps to create a file.
	• Demonstrate the steps to use different tools.

Period 2
	• Read out the rubrics in the Skill Drill section and 

encourage the students to indulge in the task 
individually.

	• Ensure that each student has completed the task.

LESSON CLOSURE
Time: 05 minutes

Purpose: Summarising the 
key points and reinforcing 
the learning outcomes of 
the lesson.

	• Discuss the answers to the questions.
	• Recapitulate the topics discussed in the lesson.

Answer Key [Chapter 4]

A.	 Tick () the correct option.
1.	 c. Text	 2.	 b. Stage	 3.	 a. playhead	 4.	 c. Animation

B.	 Fill in the blanks using the words in the box.
1.	 graphic	 2.	 Stroke	 3.	 Tools	 4.	 Button clip

C.	 Write T for True and F for False statements.
1.	 T	 2.	 F	 3.	 F	 4.	 F

D.	 Answer the following questions in a few words.
1.	 Adobe Animate is a computer animation software created by Adobe Inc. It was 

formerly known as Adobe Flash Professional. It is a powerful tool used for creating 
interactive and animated content for various purposes, including web design, 
multimedia presentations, online advertising, games, etc. 

2.	 The Properties panel is also known as the Property Inspector. It displays various 
properties of the selected object. The properties of the selected object can be 
edited by changing the settings of the object.

3.	 We use the Selection or Subselection Tool to select objects on the stage.
4.	 A symbol is a graphic, button or movie clip that we create and reuse through the 

entire project. Symbols are stored in the Library panel.
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E.	 Answer the following questions.
1.	 The steps to save a document are:

•	 Click on the File tab on the menu bar and select the Save As option. A Save As 
dialog box will appear.

•	 Type a name for the file in the File name box.
•	 Click on the Save button.

2.	 The timeline is the section provided below the stage. It is divided into frames. We 
can set or change the timing for the appearance and motion of the graphics or 
other elements of a project. The playhead can be used to navigate through the 
project and reach any frame from the timeline.

3.	 The three types of symbols are:
•	 Movie Clip Symbol: We use it to create reusable pieces of animation.
•	 Button Clip symbol: We use it to create interactive buttons that respond to 

mouse clicks, rollovers or other actions.
•	 Graphic symbol: We use graphic symbol for static images and to create reusable 

pieces of animation that are tied to the main Timeline.
4.	 The Pencil Tool is used to draw freehand lines and shapes whereas the Brush Tool 

is used to draw or paint with brush-like strokes.

5.  Computer Malware and Viruses 

Subject: Computer

Duration (Periods): 2

Lesson Name: Computer Malware and Viruses

Overview: Computer malware and viruses can affect the functioning of the computer. 

Prior Knowledge: The students are familiar with the effects of malware and viruses.

Learning Outcomes:
At the end of the lesson, the student will be able to: 

	• define malware and computer virus.

	• state the uses of antivirus and firewall.

Teaching Aids: 
	• https://i.pinimg.com/564x/72/9a/3d/729a3dd15d89d23d99703fe3bcad4dcb.jpg

	• https://i.pinimg.com/564x/86/aa/2c/86aa2ce633e9c9e3e39cbe918e818808.jpg
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Learning Segments:

LESSON LINK
Time: 05 minutes

Purpose: Brief 
introduction/discussion to 
pique students’ interest.

Greet the class and introduce the topic:
	• Malware is a malicious software that is specifically 

designed to harm, exploit or gain unauthorised 
access to computer systems.

	• A computer virus is a program designed to disrupt 
the proper operation of a computer system.

LESSON EXECUTION
Time: 25 minutes

Purpose: Engagement of 
both teacher and students 
to achieve the learning 
outcomes.

Period 1
	• Elaborate upon the different types of malware.
	• Discuss the different types of computer viruses.
	• Explain the signs of a virus infected computer and the 

ways to prevent it.
	• Emphasise on the importance of antivirus and firewall.

Period 2
	• Read out the rubrics in the Skill Drill section and 

encourage the students to indulge in the task 
individually.

	• Ensure that each student has completed the task.

LESSON CLOSURE
Time: 05 minutes

Purpose: Summarising the 
key points and reinforcing 
the learning outcomes of 
the lesson.

	• Discuss the answers to the questions.
	• Recapitulate the topics discussed in the lesson.

Answer Key [Chapter 5]

A.	 Tick () the correct option.
1.	 b. firewall	 2.	 c. Trojan horse	 3.	 a. reputable	 4.	 b. Spyware
5.	 e-mail

B.	 Fill in the blanks using the words in the box.
1.	 Malware	 2.	 computer virus	 3.	 Worm	 4.	 Ransomware
5.	 Macro virus

C.	 Write T for True and F for False statements.
1.	 T	 2.	 F	 3.	 T	 4.	 F
5.	 T
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D.	 Answer the questions in a few words.
1.	 Ransomware is a malware that seizes important data belonging to an individual or 

an organisation and demands payment in order to restore access to that data.
2.	 The full-form of MBR is Master Boot Record.
3.	 An e-mail virus contaminates the devices that receive the infected e-mail. Typically 

transmitted through an infected file attached to the e-mail, this virus can erase 
crucial data and even lead to system crashes.

4.	 The full form of VIRUS is Vital Information Resources Under Siege.
5.	 One example of an antivirus software is McAfee.

E.	 Answer the following questions.
1.	 A firewall serves as a network security device that creates a protective barrier 

between internal and public networks. Its role is to monitor incoming and outgoing 
network traffic, effectively preventing unauthorised access to a computer network.

2.	 The signs that a computer has been infected with virus are:
•	 The computer’s speed noticeably decreases.
•	 Basic tasks take longer to complete.
•	 Unexpected shutdowns occur.
•	 Unusual error messages appear repeatedly.
•	 File names and locations undergo automatic changes.
•	 Accessing stored applications becomes challenging.

3.	 The ways to prevent a virus are:
•	 Download online content exclusively from reputable websites.
•	 Refrain from using pirated software.
•	 Avoid downloading or opening e-mails sent by unfamiliar individuals.
•	 Prior to connecting external storage devices like pen drives, CDs and hard 

drives, conduct scans to prevent any threats.
•	 Consistently employ an antivirus program to shield the system.

4.	 A macro virus ises the macro language found in software like Microsoft Excel or 
Word. It is designed with the intent to infect and disrupt valuable data within such 
files.

5.	 The effects of computer viruses are:
•	 A virus has the potential to lead to a hard disk crash.
•	 By attaching itself to files before being sent via e-mail, it can spread and infect 

other computer systems.
•	 Valuable data can be lost due to a virus.
•	 A virus can execute actions without the user’s awareness or consent.
•	 Programs like Microsoft Word can be impacted by a virus.

Galaxy_DigiVerse_Book-6_TRM.indd   14Galaxy_DigiVerse_Book-6_TRM.indd   14 05-03-2024   12:05:3705-03-2024   12:05:37



Teacher’s Resource Manual 15

Subject: Computer

Duration (Periods): 2

Lesson Name: Algorithm and Flowchart 

Overview: Algorithms and flowcharts help simplify a problem.

Prior Knowledge: The students are familiar with the concept of stepwise thinking.

Learning Outcomes:
At the end of the lesson, the student will be able to: 

	• define, create algorithms and flowcharts.

	• solve problems using algorithms and flowcharts.

Teaching Aids: 
	• https://i.pinimg.com/564x/97/6a/27/976a27628d1bff7a80d712514f40b712.jpg

	• https://i.pinimg.com/564x/1e/43/8c/1e438c01772a85e505c40d3cccb7318b.jpg

Learning Segments:

LESSON LINK
Time: 05 minutes

Purpose: Brief 
introduction/discussion to 
pique students’ interest.

Greet the class and introduce the topic:
	• An algorithm is a collection of rules that can be 

sequentially followed to accomplish a task.
	• A flowchart is a visual diagram that shows an 

algorithm’s steps.

LESSON EXECUTION
Time: 25 minutes

Purpose: Engagement of 
both teacher and students 
to achieve the learning 
outcomes.

Period 1
	• Discuss the important characteristics and uses of an 

algorithm.
	• Demonstrate the steps to write an algorithm through 

various examples.
	• Explain the different symbols used in flowcharts.
	• Elaborate upon the rules to draw a flowchart.

Period 2
	• Read out the rubrics in the Skill Drill section and 

encourage the students to indulge in the task 
individually.

	• Ensure that each student has completed the task.

6.  Algorithm and Flowchart
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LESSON CLOSURE
Time: 05 minutes

Purpose: Summarising the 
key points and reinforcing  
the learning outcomes of  
the lesson.

	• Discuss the answers to the questions.
	• Recapitulate the topics discussed in the lesson.

Answer Key [Chapter 6]

A.	 Identify the following symbols and write their names.
1.	 Start/Stop	 2.	 Process	 3.	 Decision	 4.	 Input/Output
5.	 Flow Line	 6.	 Connector

B.	 Fill in the blanks using the words in the box.
1.	 algorithm	 2.	 Flowchart	 3.	 connector	 4.	 program

C.	 Write T for True and F for False statements.
1.	 T	 2.	 T	 3.	 T	 4.	 F

D.	 Answer the following questions in a few words.
1.	 One of the uses of an algorithm is data processing.
2.	 Only one flow line should derive from a process symbol.
3.	 The decision symbol indicates a question or a decision.
4.	 A flowchart should be tidy and it should maintain the flow from left to right or top 

to bottom.

E.	 Answer the following questions.
1.	 An algorithm is a collection of rules that can be sequentially followed to accomplish 

a task or attain a specific outcome. These tasks can encompass both logical and 
mathematical process. An algorithm is used for data processing, manipulation of 
data and Computer and Mathematical operations.

2.	 The characteristics of an algorithm are:
•	 Input: An algorithm needs input values for an output, which can be zero or more. 
•	 Output: An algorithm gives one or more results. 
•	 Clarity: Each algorithm step must be clear with no confusion, following a defined 

order. 
•	 Finite: An algorithm always ends after a certain number of steps. 
•	 Effectiveness: Algorithm steps should make sense and be practical. Avoid 

unnecessary repetition. 
•	 Language-neutral: An algorithm works based on concepts, not a specific 

programming language. 
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Subject: Computer

Duration (Periods): 2

Lesson Name: HTML5 and CSS3

Overview: HTML is the main language for making web documents.

Prior Knowledge: The students have used a search engine before.

Learning Outcomes:
At the end of the lesson, the student will be able to: 

	• define HTML tags and attributes.

	• create simple HTML codes.

	• understand the concept of CSS3.

Symbol Name Description

Start/Stop
•	 It is used to represent the start and end points of 

the flowchart.
•	 It generally contains the words ‘Start’ or ‘Stop’.

Process
•	 It represents a process or an action. 
•	 It is the most used symbol in flowcharts.

Decision
•	 It indicates a question or a decision.
•	 It is used to represent two options (Yes/No).

Input/Output
•	 It indicates the information entering or leaving 

the system, i.e., input and output.

3.	 A flowchart is a visual diagram that shows an algorithm’s steps. It’s like a roadmap for 
following instructions to complete a task. Flowcharts are used to understand, design, 
document and manage processes or programs. They’re crucial for programming as 
they make complex problems easier to grasp. Once a flowchart is made, writing a 
program in a high-level language becomes simpler. The advantages of a flowchart are:
•	 It ensures better understanding of a problem.
•	 It enables a programmer to analyse the problem in detail.

4.	 We use different symbols in flowcharts:

7.  HTML5 and CSS3 

Galaxy_DigiVerse_Book-6_TRM.indd   17Galaxy_DigiVerse_Book-6_TRM.indd   17 05-03-2024   12:05:3705-03-2024   12:05:37



DigiVerse 618

Teaching Aids: 
	• https://i.pinimg.com/564x/90/1b/3f/901b3f0a0206ece41f6cf69063d3cdc7.jpg

	• https://www.w3schools.com/css/css_syntax.asp

Learning Segments:

LESSON LINK
Time: 05 minutes

Purpose: Brief 
introduction/discussion to 
pique students’ interest.

Greet the class and introduce the topic:
	• HTML stands for Hypertext Markup Language.
	• HTML helps create web pages with text, links, 

headings, etc.

LESSON EXECUTION
Time: 25 minutes

Purpose: Engagement of 
both teacher and students 
to achieve the learning 
outcomes.

Period 1
	• Point out the key features of HTML.
	• Explain the meaning of tags, nesting of tags and 

attributes.
	• Discuss the basic tags and structure of an HTML 

document.
	• Introduce the students to CSS3 and its different 

styles.

Period 2
	• Read out the rubrics in the Skill Drill section and 

encourage the students to indulge in the task 
individually.

	• Ensure that each student has completed the task.

LESSON CLOSURE
Time: 05 minutes

Purpose: Summarising the 
key points and reinforcing 
the learning outcomes of 
the lesson.

	• Discuss the answers to the questions.
	• Recapitulate the topics discussed in the lesson.

Answer Key [Chapter 7]

A.	 Tick () the correct option.
1.	 b. <!DOCTYPE HTML>		  2.	 c. attribute
3.	 a. Nesting			   4.	 Markup Language

B.	 Fill in the blanks using the words in the box.
1.	 container	 2.	 Empty	 3.	 Text Level	 4.	 <BODY>

C.	 Write T for True and F for False statements.
1.	 F	 2.	 T	 3.	 T	 4.	 T
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D.	 Answer the following questions in a few words.
1.	 The two types of HTML editors are WYSIWYG editor and text editor.
2.	 In an HTML code, the values given in the container tag must always be contained 

within double quotes.
3.	 CSS stands for Cascading Style Sheets. It’s a language for designing that restructures 

web page creation. The latest version is CSS3.
4.	 The different HTML tags are: <HTML> <TITLE> <HEAD> <BODY>
5.	 The HTML editors are categorised into two types. The WYSIWYG editor allows the 

developers to preview the final appearance of their work and the basic text editors 
enable the developers to create basic HTML documents.

E.	 Answer the following questions. 
1.	 Tags form the basis of a web page, guiding the browser on how to display content. 

Although not visible on the browser, tags offer instructions for each item on the 
web page, be it text or non-text.  HTML tags are categorised as: 
•	 Container Tags: The tags that consist of both opening and closing tags are 

known as container tags. Example: <TEXT>…</TEXT> 
•	 Empty Tags: Empty tags only consist of an opening tag. Example: <HR> 
•	 Block Level Tags: These tags take up the entire available width and begin from 

the new line by default. Example: <H1>, <P>, etc. 
•	 Text Level Tags: These tags are used to markup parts of the text. Text level tags 

do not start with a new line. Some of these tags are <SUP>, <I>, <SUB>, etc. 
2.	 To gain additional information about a tag, we use attributes, enhancing the tag’s 

functionality. Attributes are always placed within the opening tag. Each attribute 
is composed of two components: the ‘name’ and the ‘value’.
•	 The ‘name’ represents the property you intend to configure for the tag. For 

instance: <BODY bgcolor=“red”>
•	 The ‘value’ signifies what you want to assign to that particular property. For 

example: <HR WIDTH=“20%”>
3.	 <HTML> tag signals the web browser that the content between <HTML> and 

</HTML> tags constitutes the web page. The code for every web page must 
commence with HTML and conclude with </HTML>.

	 <HEAD> tag establishes the web page header. Information within this tag informs 
the computer not to show it on the web page. As a container tag, it is used with 
a corresponding closing tag </HEAD>.

4.	 In an external style sheet, the CSS styles are written in a separate file which is saved 
with ‘.css’ extension. We must include a reference to the external style sheet file 
within the <LINK> element inside the <HEAD> element.
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5.	 The features of HTML5 are:
•	 Links: HTML5 helps add links to web pages. 
•	 Case Insensitive: HTML5 is not case sensitive. 
•	 User-Friendly: It’s the easiest language to learn and use. 
•	 Text Design: HTML5 easily designs webpages with text. 
•	 Tables: HTML5 allows us to create tables. 

Subject: Computer

Duration (Periods): 2

Lesson Name: Programming

Overview: Programming languages are essential for communicating with the computer

Prior Knowledge: The students have basic reasoning and logical skills.

Learning Outcomes:
At the end of the lesson, the student will be able to: 

	• understand the concept of computer languages.

	• state the features of Python.

	• write basic Python programs.

	• identify various operators in Python.

Teaching Aids: 
	• https://www.w3schools.com/python/python_intro.asp

	• https://www.w3schools.com/python/python_operators.asp

Learning Segments:

LESSON LINK
Time: 05 minutes

Purpose: Brief 
introduction/discussion to 
pique students’ interest.

Greet the class and introduce the topic:
	• Programming languages convey instructions to the 

computer for various tasks.
	• Python is a high-level programming language, 

developed by Guido van Rossum.

8.  Programming 
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LESSON EXECUTION
Time: 25 minutes

Purpose: Engagement of 
both teacher and students 
to achieve the learning 
outcomes.

Period 1
	• Discuss the categories of computer languages.
	• Explain the meaning of a language translator.
	• Discuss the features of Python.
	• Demonstrate the method of working in the interactive 

or script mode.
	• Elaborate upon the concept of variables, data types 

and comments in Python.
	• Discuss the different types of operators.

Period 2
	• Read out the rubrics in the Skill Drill section and 

encourage the students to indulge in the task 
individually.

	• Ensure that each student has completed the task.

LESSON CLOSURE
Time: 05 minutes

Purpose: Summarising the 
key points and reinforcing 
the learning outcomes of 
the lesson.

	• Discuss the answers to the questions.
	• Recapitulate the topics discussed in the lesson.

Answer Key [Chapter 8]

A.	 Tick () the correct option.
1.	 c. comments	 2.	 c. identifiers	 3.	 a. Logical	 4.	 c. Assembly
5.	 c. #

B.	 Fill in the blanks using the words in the box.
1.	 variable	 2.	 high-level	 3.	 programming	 4.	 Machine
5.	 operators

C.	 Write T for True and F for False statements.
1.	 F	 2.	 T	 3.	 T	 4.	 F
5.	 F

D.	 Answer the following questions in a few words.
1.	 The data types in Python are int, float and string.
2.	 The addition (+) arithmetic operator is used to add two operators and the 

subtraction (-) arithmetic operator is used to subtract the second operand from 
the first operand.
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3.	 Two examples of third-generation language include C++ and Java.
4.	 The input () function reads the user’s input when a program executes.
5.	 The order in which the operators are executed is determined by the precedence 

of operators.

E.	 Answer the following questions.
1.	 The features of Python are:

•	 Easy Coding: Python makes programming simpler compared to other high-level 
languages. Its syntax resembles English language.

•	 Open-Source: Python is free and open-source, allowing easy improvement and 
distribution. It can be downloaded for free on various operating systems like 
Windows, Mac, or Linux.

•	 Object-Oriented: Python uses an object-oriented approach, designing programs 
with interacting objects and classes.

•	 Integrated and Extensible: Python can blend with other languages like C or 
C++. Python code can be written and compiled in C or C++.

•	 Interpreted Language: Python executes code line by line, aiding error correction. 
It’s converted into an intermediate form (byte code) during execution, enabling 
future execution.

•	 Dynamically Typed: Python is dynamically typed, eliminating the need to declare 
variable types in advance. 

2.	 The Interactive programming mode in Python is a command line shell that provides 
immediate result for each command. We can type one command at a time in this 
mode. Python then executes the command and gives the output.

3.	 The relational operators compare values and return either True or False whereas 
the logical operators perform operations on True or False.

4.	 A low-level programming language is machine-dependent, meaning that it’s tailored 
to a specific computer. A program written in a low-level language works solely on 
one type of computer.

	 A high-level language enables programmers to create machine-independent 
programs. These languages are closer to human languages in structure. High-level 
languages are more readable, writeable and maintainable compared to low-level 
languages.

5.	 The steps to save a Python program are:
•	 Click on the File menu.
•	 Select the Save option. The Save As dialog box will appear.
•	 Select the desired location to save the file.
•	 Enter the name of the file in the File name box.
•	 Click on the Save button. The file will be saved at the selected location.
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Subject: Computer

Duration (Periods): 2

Lesson Name: Intelligence and AI Approaches

Overview: There are different categories and approaches of AI

Prior Knowledge: The students are familiar with the concept of artificial intelligence.

Learning Outcomes:
At the end of the lesson, the student will be able to:

	• state the different types of intelligence.

	• recapitulate the concept of artificial intelligence.
	• state the various AI approaches.

Teaching Aids:
	• https://i.pinimg.com/736x/90/8f/8a/908f8adbc428b6999a23303dec9d2dee.jpg

	• https://www.javatpoint.com/approaches-to-ai-learning

Learning Segments:

LESSON LINK
Time: 05 minutes

Purpose: Brief 
introduction/discussion to 
pique students’ interest.

Greet the class and introduce the topic:
	• Intelligence is the skill to learn, understand and think 

logically.
	• Artificial intelligence refers to a computer or robot’s 

capability to perform tasks linked to intelligent 
beings.

LESSON EXECUTION
Time: 25 minutes

Purpose: Engagement of 
both teacher and students 
to achieve the learning 
outcomes.

Period 1
	• Elaborate upon the theory of Multiple Intelligences 

by Howard Gardner.
	• Discuss the categories of AI.
	• Explain the approaches to AI.

Period 2
	• Read out the rubrics in the Skill Drill section and 

encourage the students to indulge in the task 
individually.

	• Ensure that each student has completed the task.

9.  Intelligence and AI Approaches 
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LESSON CLOSURE
Time: 05 minutes

Purpose: Summarising the 
key points and reinforcing 
the learning outcomes of 
the lesson.

	• Discuss the answers to the questions.
	• Recapitulate the topics discussed in the lesson.

Answer Key [Chapter 9]

A.	 Tick () the correct option.
1.	 c. Howard Gardner	 2.	 a. musical	 3.	 a. Limited	 4.	 c. naturalistic

B.	 Fill in the blanks using the words in the box.
1.	 Intelligence	 2.	 Reactive	 3.	 8	 4.	 Spatial

C.	 Write T for True and F for False statements.
1.	 T	 2.	 T	 3.	 F	 4.	 T

D.	 Answer the questions in a few words.
1.	 ‘Theory of mind’ is the type of AI that is still emerging. It is equipped with decision-

making skills and human-like emotions. Sophia, a humanoid robot, is an example 
of this category.

2.	 The bodily-kinesthetic intelligence consists the use of body flexibly and creatively.
3.	 Linguistic intelligence allows an individual to be fluent in a language in order to 

express thoughts and emotions.

E.	 Answer the following questions
1.	 Intelligence is the skill to learn, understand and think logically whereas Artificial 

Intelligence (AI) is the ability of a digital computer or computer-controlled robot 
to perform tasks commonly associated with intelligent beings.

2.	 Reactive machines can execute tasks based on specific instructions but lack memory 
or learning from past experiences. For example, IBM’s Deep Blue defeated chess 
Grandmaster Garry Kasparov.

3.	 The logical-mathematical intelligence allows people to think logically and interpret 
symbols to solve mathematical problems.

4.	 The intrapersonal intelligence allows people to have an understanding of their own 
feelings and emotions.
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Subject: Computer

Duration (Periods): 2

Lesson Name: ChatGPT

Overview: ChatGPT is a language model developed by OpenAI.

Prior Knowledge: The students have basic understanding of language and communication. 

Learning Outcomes:
At the end of the lesson, the student will be able to:

	• understand the concept of ChatGPT.

	• use ChatGPT for various queries.

Teaching Aids:
	• https://i.pinimg.com/564x/39/95/5a/39955ab995b5b734e29d5182806fffed.jpg

	• https://www.techtarget.com/whatis/definition/ChatGPT

Learning Segments:

LESSON LINK
Time: 05 minutes

Purpose: Brief 
introduction/discussion to 
pique students’ interest.

Greet the class and introduce the topic:
	• ChatGPT is based on GPT-3, which stands for 

Generative Pre-trained Transformer-3.
	• The GPT-3 model is known for its ability to generate 

coherent and contextually relevant text. 

LESSON EXECUTION
Time: 25 minutes

Purpose: Engagement of 
both teacher and students 
to achieve the learning 
outcomes.

Period 1
	• Explain the usage of ChatGPT.
	• Elaborate upon the key features of ChatGPT.
	• Explain the ways to interact with ChatGPT.

Period 2
	• Read out the rubrics in the Skill Drill section and 

encourage the students to indulge in the task 
individually.

	• Ensure that each student has completed the task.

LESSON CLOSURE
Time: 05 minutes

Purpose: Summarising the 
key points and reinforcing 
the learning outcomes of 
the lesson.

	• Discuss the answers to the questions.
	• Recapitulate the topics discussed in the lesson.

10.  ChatGPT
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Answer Key [Chapter 10]

A.	 In the space given below, write some samples of questions that you might ask ChatGPT 
to answer.
Question 1.  (Subjective)
Question 2.  (Subjective)
Question 3.  (Subjective)
Question 4.  (Subjective)
Question 5.  (Subjective)

B.	 Answer the following questions.
1.	 ChatGPT is a language model developed by OpenAI, and it’s built upon the GPT 

(Generative Pre-trained Transformer) architecture.
2.	 The key features of ChatGPT are:

•	 Architecture: GPT-3 employs a transformer architecture, which is a type of neural 
network architecture that excels at handling sequential data, such as text. The 
transformer architecture’s attention mechanisms allow the model to capture 
dependencies between words in a sentence and generate coherent responses.

•	 Pre-training: GPT-3 is pre-trained on a massive amount of text data from the internet. 
This pre-training phase involves predicting the next word in a sentence, which helps 
the model learn grammar, vocabulary, and some level of world knowledge.

•	 Scale: One of the standout features of GPT-3 is its sheer scale. It has 175 billion 
parameters, making it one of the largest publicly known language models at 
the time. The large number of parameters allows the model to capture complex 
patterns in data and generate high-quality text.

•	 Fine-tuning: After pre-training, GPT-3 can be fine-tuned on specific tasks using a 
smaller dataset. This allows the model to adapt to more specific tasks, making it 
useful for a wide variety of applications, including chatbots, content generation, 
code completion, translation, and more.

3.	 A general guide to use ChatGPT is:
•	 Access the Platform: OpenAI provides various platforms and interfaces where 

you can access ChatGPT. This could be through their website, APIs (Application 
Programming Interfaces), or third-party applications that integrate ChatGPT.

•	 Enter Text Prompt: Once you’re on the platform, you’ll see a text box where you 
can enter your prompt or message. This is what you want to talk to ChatGPT 
about or ask for assistance with.

•	 Receive Response: After entering your prompt, submit it to the system. ChatGPT 
will process your input and generate a response based on its understanding of 
the text. The response will appear on the screen.

•	 Continue the Conversation: You can continue the conversation by entering 
new prompts or questions based on the context of the conversation. ChatGPT 
will use its understanding of the conversation history to generate relevant and 
coherent responses.
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•	 Experiment with Instructions: You can experiment with different types of prompts 
and instructions to guide the model’s behavior. For example, you can ask it to 
summarize a topic, generate creative writing, provide explanations, and more.

•	 Iterate and Refine: If the initial response isn’t exactly what you’re looking for, you 
can iterate and refine your prompts to get the desired output. Experimenting 
with different phrasings and instructions can help you achieve the best results. 

Worksheet 1

A.	 Define the following.
1.	 Action Buttons are built-in shapes that perform a specified action once we click 

or hover the mouse pointer over them. We can specify the action of each Action 
Button that we add to the slide.

2.	 Cut command removes the data from its original place.
3.	 We merge the cells when we want to display two or more sub-headings for a main 

heading.
4.	 Cell Styles can be used to emphasise important data or to enhance the appearance 

of the data.
5.	 The location of the cell in a worksheet is known as the cell reference.

B.	 Write the steps in brief.
1.	 Insert > Video >Video on My PC/Online Videos 
2.	 Right-click on Sheet Tab > Rename / Tab Color
3.	 File > Print > Print All Slides > Print Layout > Print
4.	 Select the cells > Home > Number Format box > Number Format
5.	 Select the range > Formulas > Define Name > New Name > OK

C.	 Application-based questions.
1.	 Sahil will use the ‘Record Audio’ option to insert a recorded audio in the presentation.
2.	 Shreya will use the MAX () function to derive the maximum roll number.

Worksheet 2

A.	 Define the following.
1.	 The timeline is the section provided below the stage. It is divided into frames. We 

can set or change the timing for the appearance and motion of the graphics or 
other elements of a project. The playhead can be used to navigate through the 
project and reach any frame from the timeline.

2.	 A computer virus is a program designed to disrupt the proper orientation of the 
computer system. The term VIRUS stands for Vital Information Resources Under 
Siege.
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3.	 The Eyedropper Tool picks up styles of existing lines, fills and text and applies them 
to other objects.

4.	 A firewall serves as a network security device that creates a protective barrier 
between internal and public networks. Its role is to monitor incoming and outgoing 
network traffic, effectively preventing unauthorised access to a computer network.

5.	 We use graphic symbol for static images and to create reusable pieces of animation 
that are tied to the main Timeline.

B.	 Write the steps in brief.
1.	 Start > Start Menu > Adobe Animate 2020
2.	 Selection Tool > Select shape > Modify > Convert to Symbol > Convert to Symbol 

dialog box > OK
3.	 Selection Tool > Select the shape > Window > Color > Color Panel > Color Type >  

Gradient Fill 
4.	 Tools Panel > Oval Tool > Fill and Stroke Color > Draw on stage > Properties Panel >  

Stroke Size
5.	 File > Save As > File name > Save

C.	 Application-based questions.
1.	 An antivirus software will help Muskan to keep her files secure.
2.	 Sudha will use the Button Clip symbol to create interactive buttons in Animate CC.

Worksheet 3

A.	 Define the following.
1.	 An algorithm is a collection of rules that can be sequentially followed to accomplish 

a task or attain a specific outcome. These tasks can encompass both logical and 
mathematical process.

2.	 A flowchart is a visual diagram that shows an algorithm’s steps. It’s like a roadmap 
for following instructions to complete a task. Flowcharts are used to understand, 
design, document and manage processes or programs. 

3.	 The tags that consist of both opening and closing tags are known as container tags. 
Example: <TEXT>…</TEXT>

4.	 Flowchart are crucial for programming as they make complex problems easier 
to grasp. Once a flowchart is made, writing a program in a high-level language 
becomes simpler.

5.	 The person who creates the programs is known as the programmer

B.	 Write the steps in short form.
1.	 Notepad > File > Save As > File Name > Save
2.	 URL > Downloads > Download Python 3.11.5 > Set up > Run > Add Python 3.11.5 

to PATH > Install Now
3.	 Python IDLE > File > New File
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C.	 Application-based questions.
1.	 The ‘Run Module’ option in the Run menu will execute a program in Python.
2.	 Reyhaan will use the empty tags.

Worksheet 4

A.	 Define the following.
1.	 Reactive machines can execute tasks based on specific instructions but lack memory 

or learning from past experiences. For example, IBM’s Deep Blue defeated chess 
Grandmaster Garry Kasparov.

2.	 Intelligence is the skill to learn, understand and think logically.
3.	 Linguistic intelligence allows an individual to be fluent in a language in order to 

express thoughts and emotions.
4.	 ChatGPT is a language model developed by OpenAI, and it’s built upon the GPT 

(Generative Pre-trained Transformer) architecture.
5.	 Artificial Intelligence (AI) is the ability of a digital computer or computer-controlled 

robot to perform tasks commonly associated with intelligent beings.

B.	 In the space given below, write two ways to interact with ChatGPT.
1.	 Access the Platform: OpenAI provides various platforms and interfaces where 

you can access ChatGPT. This could be through their website, APIs (Application 
Programming Interfaces), or third-party applications that integrate ChatGPT.

2.	 Enter Text Prompt: Once you’re on the platform, you’ll see a text box where you 
can enter your prompt or message. This is what you want to talk to ChatGPT about 
or ask for assistance with.

C.	 State the types of intelligence portrayed by the following.
1.	 Musical Intelligence
2.	 Bodily-Kinesthetic Intelligence
3.	 Intrapersonal and Linguistic Intelligence
4.	 Intrapersonal Intelligence

Test Paper 1

A.	 Tick () the correct option.
1.	 b. File	 2.	 a. Fill Handle	 3.	 b. largest	 4.	 b. Stage
5.	 c. Trojan Horse

B.	 Fill in the blanks.
1.	 Record Audio	 2.	 AutoFill	 3.	 equal to (=)	 4.	 Tools
5.	 Ransomware

C.	 Write T for True and F for False statements.
1.	 F	 2.	 T	 3.	 T	 4.	 T
5.	 T
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D.	 Answer the questions in a few words.
1.	 We add video files from the Insert tab.
2.	 Splitting the cell means dividing it into more cells.
3.	 Functions in Excel are like ready-made formulas. They handle calculations, both 

simple and complex, by taking inputs (arguments) and showing results in cells.
4.	 A symbol is a graphic, button or movie clip that we create and reuse through the 

entire project. Symbols are stored in the Library panel.  
5.	 An e-mail virus contaminates the devices that receive the infected e-mail. Typically 

transmitted through an infected file attached to the e-mail, this virus can erase 
crucial data and even lead to system crashes.

E.	 Answer the following questions.
1.	 If we choose the Mouse Over tab in the Action Settings dialog box, then we can 

hover the mouse pointer over the Action Button and it will perform the assigned 
action.

2.	 The steps to change the row height are:
•	 Select the row(s) to change its height.
•	 Click on the Home tab and select the Format command from the Cells group. 

A drop-down menu will appear.
•	 Select the Row Height option from the Cell Size heading. A Column Width or 

Row Height dialog box will appear on the screen.
•	 Type the value in the Row Height box to define the row height.
•	 Click on the OK button to see the changes.

3.	 The rules to follow while entering a function in Excel are:
•	 Every Excel function starts with an equal (=) sign.
•	 We need to use a valid Excel function name.
•	 Open and close parentheses are necessary after mentioning a function.
•	 For most functions, including an argument within the parentheses is required.

4.	 The Pencil Tool is used to draw freehand lines and shapes whereas the Brush Tool 
is used to draw or paint with brush-like strokes.

5.	 The effects of computer viruses are:
•	 A virus has the potential to lead to a hard disk crash.
•	 By attaching itself to files before being sent via e-mail, it can spread and infect 

other computer systems.
•	 Valuable data can be lost due to a virus.
•	 A virus can execute actions without the user’s awareness or consent.
•	 Programs like Microsoft Word can be impacted by a virus.
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Test Paper 2

A.	 Tick () the correct option.
1.	 b. <!DOCTYPE HTML>		  2.	 a. data processing
3.	 c. identifiers			   4.	 a. 8
5.	 a. Limited

B.	 Fill in the blanks.
1.	 connector	 2.	 Text level	 3.	 variable	 4.	. html
5.	 8

C.	 Write T for True and F for False statements.
1.	 T	 2.	 T	 3.	 F	 4.	 F
5.	 F

D.	 Answer the questions in a few words.
1.	 One of the uses of an algorithm is data processing.
2.	 There are three types of style sheets in CSS3: Inline Style Sheet, Internal Style Sheet, 

External Style Sheet
3.	 The data types in Python are int, float and string.
4.	 The person who creates the program is known as a programmer.
5.	 ‘Theory of mind’ is the type of AI that is still emerging. It is equipped with decision-

making skills and human-like emotions. Sophia, a humanoid robot, is an example 
of this category.

E.	 Answer the following questions.
1.	 A flowchart is a visual diagram that shows an algorithm’s steps. It’s like a roadmap for 

following instructions to complete a task. Flowcharts are used to understand, design, 
document and manage processes or programs. They’re crucial for programming as 
they make complex problems easier to grasp. Once a flowchart is made, writing a 
program in a high-level language becomes simpler. The advantages of a flowchart are:
•	 It ensures better understanding of a problem.
•	 It enables a programmer to analyse the problem in detail.

2.	 The Interactive programming mode in Python is a command line shell that provides 
immediate result for each command. We can type one command at a time in this 
mode. Python then executes the command and gives the output.

3.	 When you open a new tag before closing the previous one, it is called nesting of 
tags. These tags follow the Last In First Out (LIFO) principle, which means that the 
tag opened last must be closed first. This principle ensures that the most recently 
opened tag is closed before the others.
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  1.  c.	   2.  c.	 3.  b.	 4.  d.	 5.  d.	 6.  d.

  7.  d.	   8.  d.	 9.  a.	 10.  d.	 11.  a.	 12.  b.
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4.	 In an external style sheet, the CSS styles are written in a separate file which is saved 
with ‘.css’ extension. We must include a reference to the external style sheet file 
within the <LINK> element inside the <HEAD> element.

5.	 The features of ChatGPT are:
•	 Architecture: GPT-3 employs a transformer architecture, which is a type of neural 

network architecture that excels at handling sequential data, such as text. The 
transformer architecture’s attention mechanisms allow the model to capture 
dependencies between words in a sentence and generate coherent responses.

•	 Pre-training: GPT-3 is pre-trained on a massive amount of text data from the 
internet. This pre-training phase involves predicting the next word in a sentence, 
which helps the model learn grammar, vocabulary, and some level of world 
knowledge.

•	 Scale: One of the standout features of GPT-3 is its sheer scale. It has 175 billion 
parameters, making it one of the largest publicly known language models at 
the time. The large number of parameters allows the model to capture complex 
patterns in data and generate high-quality text.

•	 Fine-tuning: After pre-training, GPT-3 can be fine-tuned on specific tasks using a 
smaller dataset. This allows the model to adapt to more specific tasks, making it 
useful for a wide variety of applications, including chatbots, content generation, 
code completion, translation, and more.
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